Instagram     

Go Back   PNW Moto > PNW Moto > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions

Like Tree12Likes
Reply
 
Thread Tools
Jul 14th 2017, 09:54 AM   #16
 DarthVader's Avatar
 
  Mar 2016
  SaLeM

  nothing! :(
Quote:
Originally Posted by Suzuki Stevo
Today's fuel goes to Crap quickly, how old is the fuel? I say go find a hill
only run non ethanol in it...fuel less than 2 months old!
Jul 14th 2017, 09:57 AM   #17
 DarthVader's Avatar
 
  Mar 2016
  SaLeM

  nothing! :(
Quote:
Originally Posted by Red Label Moto
My idea is that you go with your gut feeling and follow your own advice. Whether or not you make it run is actually beside the point. Less hassles/less clutter in life are the keys to happiness. A few bucks here or there (the difference between selling it running or not) won't count for much in the long run.

The most professional/well run motorcycle store in the white hot economic epicenter known as Seattle recently decided that having Royal Enfield was a better option than representing KTM to the public.

What does that tell you ?
yeah...been hearing this a lot about the RC390....have talked with a few dealers that have been thinking to drop KTM due to these issues....there old dirt bikes are awesome, wish they had put in the effort to make this bike as good, to bad they didnt!....I think I will try to figure this out and get it going for now...and then sell it off....just dont trust the bike now!
Jul 15th 2017, 06:22 AM   #18
 
  Jan 2016
  Kennewick

  Depends on my mood.
Did it quit running after you did something to the bike? If so, Undo it

If it was running fine, then mysteriously crapped out, then I am still no help.

Dusty
Jul 15th 2017, 07:22 AM   #19
 
  Apr 2016
  WA

If you haven't already go check and post on KTM RC390 Forum

Lots of knowledge over there.
Jul 15th 2017, 08:07 AM   #20
 DarthVader's Avatar
 
  Mar 2016
  SaLeM

  nothing! :(
Quote:
Originally Posted by Bald Guy
Did it quit running after you did something to the bike? If so, Undo it

If it was running fine, then mysteriously crapped out, then I am still no help.

Dusty
had a little over 400 miles on it after doing its valve adjust....riding it home after a short ride, and while riding it, it stopped running!...has not run since....acted like no spark or no fuel....would not bump start......thinking that it may have got something in fuel line when I had it apart, and now clogged up injector.(tested injector, and it does have a little fuel going through it, but not like it should!)..have injector on order,should have it in next week or so. will see if that fixes the problem!
Jul 15th 2017, 08:19 AM   #21
 Spydrmon's Avatar
 
  Mar 2016
  Bothell

Injector is a good call as Silvie suggested earlier. Good luck.
Jul 15th 2017, 01:22 PM   #22
 Sentinel's Avatar
 
  Jun 2016
  Poor Tortured

  2015 Kawasaki Concours 14 - The Origame Dragon
bad fuel?
water in fuel?
drain and refill.
clean screen/filter.
add SeaFoam.

or maybe - the on/off switch wire is loose or the switch is bad?
kickstand switch?
tip-over sensor?

does the fuel pump whir when you turn on the key?

Edited by Sentinel on Jul 15th 2017 at 01:27 PM
Jul 15th 2017, 05:25 PM   #23
 Arnbo's Avatar
 
  Jan 2016
  Ferndale Washington

  ZX10-R GSXR 600 Track Bike
Curse of the ZX-14 who pleaded not to be traded.....So who's fault is it?
Jul 15th 2017, 06:12 PM   #24
 Wrench's Avatar
 
  Jan 2016
  West Richland, WA

Ignition timing is way off?

If it didn't run on starting fluid being shot in the intake, I would say it is an electrical problem.
Jul 15th 2017, 06:19 PM   #25
 BarryMcCockener's Avatar
 
  Feb 2016
  Shelton (little Arakansas)

Have a dealer check the error codes...
DarthVader likes this.
Jul 15th 2017, 07:17 PM   #26
 DocB's Avatar
 
  Feb 2016
  Poulsbo, WA

  Aprilia RSV Mille, CB77, CB750K, CB750F
If the injector is easy to remove they are usually pretty easy to test using a 9V battery, a bit of fuel line and some carb cleaner.
Jul 15th 2017, 07:48 PM   #27
 SilvieFox's Avatar
 
  Jan 2016
  welches, Oregon

  2008 Kawasaki Versys (Sylvester), 1972 Suzuki RV90 (vanvan), 1981 Honda TwinStar (Bobber),yamaha 225
Quote:
Originally Posted by DocB
If the injector is easy to remove they are usually pretty easy to test using a 9V battery, a bit of fuel line and some carb cleaner.
put the body part of a seasoning syringe at the end of the fuel line and it makes a good reservoir to fill with carb cleaner
DocB and Mudslinger like this.
Jul 16th 2017, 06:27 AM   #28
 
  Apr 2016
  WA

Valve adjustment you say..... Who did it? Get a measurement a little tight and burn an exhaust valve? Shim slip out and hang an intake open?
Jul 16th 2017, 07:01 AM   #29
 Wrench's Avatar
 
  Jan 2016
  West Richland, WA

Quote:
Originally Posted by Ryanthegreat1
Valve adjustment you say..... Who did it? Get a measurement a little tight and burn an exhaust valve? Shim slip out and hang an intake open?
This should show on a compression test.

OP:
What was the compression? You said it was "good", how was it tested?

I still think it is an electrical issue related to spark. "Sudden" shut down and no running when starting fluid is sprayed into intake really does not correspond with a fueling problem.

Fresh plugs with the correct spark gap? All coil connections good? All ECU connections good? A connection that was disconnected for access to the valves not get connected fully and wiggle loose? Check all connections and be sure there are no pins backing out either.
SilvieFox likes this.

Edited by Wrench on Jul 16th 2017 at 07:04 AM
Jul 16th 2017, 02:00 PM   #30
 
  Apr 2016
  WA

Check all the connections around the throttle body. There is a rubber bib over the engine that has to be removed to service the valves. To get the bib off all the electrical connections around the throttle body get unplugged.

Also there is a ground for the ECU on the frame rail under the left edge of the tank that gets removed during service.

And I seem to recall the idle air connector likes to vibrate loose. Race bikes wire ties them in place.
Reply

  PNW Moto > PNW Moto > Mechanical and Technical

Tags
2015, ktm, rc390, start



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Honda Nighthawk Clutch wont disengage take risks Mechanical and Technical 9 May 24th 2017 05:40 AM
For Sale: 2015 ktm rc390 - clean & low miles!!! RECR8TON Classifieds 1 Jun 16th 2016 03:58 PM
KTM RC390 Andreani Suspension jared p Marketplace 2 May 26th 2016 08:57 AM
someone start it Bill98579 Olympia 2 Mar 18th 2016 02:00 PM
Start A New Balut Bellingham 26 Feb 12th 2016 11:36 PM




Copyright © 2017 PNW Moto. All rights reserved.